$re = '/([^a])aa([^a])/m';
$str = '#aa
.aa
#aa>
#aa{
#aa+
#aa
#aa{
#aaa{
test#aa{';
$subst = "$1abcd$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;