#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)([^a])aa([^a])"
Local $sString = "#aa" & @CRLF & _
".aa" & @CRLF & _
"#aa>" & @CRLF & _
"#aa{" & @CRLF & _
"#aa+" & @CRLF & _
"#aa" & @CRLF & _
"#aa{" & @CRLF & _
"#aaa{ " & @CRLF & _
"test#aa{"
Local $sSubst = "$1abcd$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)