import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^|[^\\d.])(0(?:\\.\\d{0,2})?|1(?:\\.0{0,2})?)(?=([^\\d.]|$))";
final String string = "0.00\n"
+ "1.00\n"
+ "2.0\n"
+ "1.01\n"
+ "0.02\n"
+ "0.04\n\n\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}