re = /(?:^|[^\d.])(0(?:\.\d{0,2})?|1(?:\.0{0,2})?)(?=([^\d.]|$))/
str = '0.00
1.00
2.0
1.01
0.02
0.04
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end