const regex = /(?:^|[^\d.])(0(?:\.\d{0,2})?|1(?:\.0{0,2})?)(?=([^\d.]|$))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^|[^\\d.])(0(?:\\.\\d{0,2})?|1(?:\\.0{0,2})?)(?=([^\\d.]|$))', 'g')
const str = `0.00
1.00
2.0
1.01
0.02
0.04
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}