using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([^\s\|]+)\|([^\|]+)\|([^\|]+)";
string substitution = @"";
string input = @"sample-search-cdn|nz|nz--cdn|||||generic-produce-luxury-gdn|||generic-value|||| ";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}