re = /^([^\s\|]+)\|([^\|]+)\|([^\|]+)/
str = 'sample-search-cdn|nz|nz--cdn|||||generic-produce-luxury-gdn|||generic-value|||| '
subst = ''
result = str.sub(re, subst)
# Print the result of the substitution
puts result