package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([^\s\|]+)\|([^\|]+)\|([^\|]+)`)
var str = []byte(`sample-search-cdn|nz|nz--cdn|||||generic-produce-luxury-gdn|||generic-value|||| `)
var substitution = []byte("")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}