import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?P<content>(?:[-/][a-zA-Z0-9\\-_]+)?=?)(?P<prefix>bazel-out|external)/";
final String string = "-Ibazel-out/k8-fastbuild/include\" → Matches bazel-out/\n"
+ "-Lexternal/foo/lib\" → Matches external/\n"
+ "--gcc-toolchain=bazel-out/toolchain\" → Matches bazel-out/\n"
+ "-fmodule-output=external/module.pcm\" → Matches external/\n"
+ "/Ibazel-out/k8-fastbuild/include\" (MSVC, Windows) → Matches bazel-out\\\n"
+ "--extract-api-ignores=external/bar,baz\" → Matches external/\n"
+ "bazel-out/k8-fastbuild/source.c\" (file field) → Matches bazel-out/\n\n"
+ "Should Not Match\n\n"
+ "-Ifoo/bazel-out/bar\" (nested path) → No match\n"
+ "-Dmacro=bazel-out_value\" (not a path) → No match\n"
+ "bazel-output/include\" (similar name) → No match\n"
+ "-I externals/foo\" (similar name) → No match\n"
+ "-I bazel-out/...\" (space after -I) → No match (separate flags)";
final String subst = "\\g<content>dynamically-matched-new-prefix/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}