re = /^(?P<content>(?:[-\/][a-zA-Z0-9\-_]+)?=?)(?P<prefix>bazel-out|external)\//m
str = '-Ibazel-out/k8-fastbuild/include" → Matches bazel-out/
-Lexternal/foo/lib" → Matches external/
--gcc-toolchain=bazel-out/toolchain" → Matches bazel-out/
-fmodule-output=external/module.pcm" → Matches external/
/Ibazel-out/k8-fastbuild/include" (MSVC, Windows) → Matches bazel-out\\
--extract-api-ignores=external/bar,baz" → Matches external/
bazel-out/k8-fastbuild/source.c" (file field) → Matches bazel-out/
Should Not Match
-Ifoo/bazel-out/bar" (nested path) → No match
-Dmacro=bazel-out_value" (not a path) → No match
bazel-output/include" (similar name) → No match
-I externals/foo" (similar name) → No match
-I bazel-out/..." (space after -I) → No match (separate flags)'
subst = '\\g<content>dynamically-matched-new-prefix/'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result