# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?P<content>(?:[-/][a-zA-Z0-9\-_]+)?=?)(?P<prefix>bazel-out|external)/"
test_str = ("-Ibazel-out/k8-fastbuild/include\" → Matches bazel-out/\n"
"-Lexternal/foo/lib\" → Matches external/\n"
"--gcc-toolchain=bazel-out/toolchain\" → Matches bazel-out/\n"
"-fmodule-output=external/module.pcm\" → Matches external/\n"
"/Ibazel-out/k8-fastbuild/include\" (MSVC, Windows) → Matches bazel-out\\\n"
"--extract-api-ignores=external/bar,baz\" → Matches external/\n"
"bazel-out/k8-fastbuild/source.c\" (file field) → Matches bazel-out/\n\n"
"Should Not Match\n\n"
"-Ifoo/bazel-out/bar\" (nested path) → No match\n"
"-Dmacro=bazel-out_value\" (not a path) → No match\n"
"bazel-output/include\" (similar name) → No match\n"
"-I externals/foo\" (similar name) → No match\n"
"-I bazel-out/...\" (space after -I) → No match (separate flags)")
subst = "\\g<content>dynamically-matched-new-prefix/"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.