package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((((\d{1,3})\D{1,5}){3})(\d{1,3}))$`)
var str = `112(dot)115(dot)48(dot)582`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}