const regex = /((((\d{1,3})\D{1,5}){3})(\d{1,3}))$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((((\\d{1,3})\\D{1,5}){3})(\\d{1,3}))$', '')
const str = `112(dot)115(dot)48(dot)582`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}