import Foundation
let pattern = #"((((\d{1,3})\D{1,5}){3})(\d{1,3}))$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"112(dot)115(dot)48(dot)582"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}