$re = '/((((\d{1,3})\D{1,5}){3})(\d{1,3}))$/';
$str = '112(dot)115(dot)48(dot)582';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);