const regex = /(\/\w{30,50})(.*?\1){3,}/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\\/\\w{30,50})(.*?\\1){3,}', '')
const str = `http://spam.com/hello/world/fk59j356jss5ptttNMdlJ96vmrDsjEeCPDXJf0fBXOiasasdasdasdasdasdasd/fk59j356jss5ptttNMdlJ96vmrDsjEeCPDXJf0fBXOi/fk59j356jss5ptttNMdlJ96vmrDsjEeCPDXJf0fBXOi/fk59j356jss5ptttNMdlJ96vmrDsjEeCPDXJf0fBXOi`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}