import Foundation
let pattern = #"(\/\w{30,50})(.*?\1){3,}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"http://spam.com/hello/world/fk59j356jss5ptttNMdlJ96vmrDsjEeCPDXJf0fBXOiasasdasdasdasdasdasd/fk59j356jss5ptttNMdlJ96vmrDsjEeCPDXJf0fBXOi/fk59j356jss5ptttNMdlJ96vmrDsjEeCPDXJf0fBXOi/fk59j356jss5ptttNMdlJ96vmrDsjEeCPDXJf0fBXOi"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}