$re = '/(\/\w{30,50})(.*?\1){3,}/';
$str = 'http://spam.com/hello/world/fk59j356jss5ptttNMdlJ96vmrDsjEeCPDXJf0fBXOiasasdasdasdasdasdasd/fk59j356jss5ptttNMdlJ96vmrDsjEeCPDXJf0fBXOi/fk59j356jss5ptttNMdlJ96vmrDsjEeCPDXJf0fBXOi/fk59j356jss5ptttNMdlJ96vmrDsjEeCPDXJf0fBXOi';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);