re = /(\/\w{30,50})(.*?\1){3,}/
str = 'http://spam.com/hello/world/fk59j356jss5ptttNMdlJ96vmrDsjEeCPDXJf0fBXOiasasdasdasdasdasdasd/fk59j356jss5ptttNMdlJ96vmrDsjEeCPDXJf0fBXOi/fk59j356jss5ptttNMdlJ96vmrDsjEeCPDXJf0fBXOi/fk59j356jss5ptttNMdlJ96vmrDsjEeCPDXJf0fBXOi'
# Print the match result
str.match(re) do |match|
puts match.to_s
end