import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)^([A-Za-z][0-9]{1,2})|(([A-Za-z][A-Za-z][0-9]{1,2})|(([AZa-z][0-9][A-Za-z])|([A-Za-z][A-Za-z][0-9][A-Za-z]?)))? ?[0-9][A-Za-z]{2}$";
final String string = "Ivy Cottage, Rockley,SN81RT\n"
+ "11 Brabourne Gardens, North Shields,NE299JB\n"
+ "2 Russell Gardens, Whitchurch,RG287AY\n"
+ "14 Red Barns, Newcastle Upon Tyne,NE12TP\n"
+ "1 Hollybank, Tamworth Road, Lichfield,WS149JE\n"
+ "69 Burnlee Road, Holmfirth,HD92PS\n"
+ "30 Cashio Lane, Letchworth Garden City,SG61AX\n"
+ "14 Cedartree Gardens, Whitley Bay,NE258XN\n"
+ "518A Victoria Road, Ruislip,HA40HD\n"
+ "9 Pear Avenue, Leeds,LS168GT\n";
final String subst = "$0@";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}