import Foundation
let pattern = #"(?m)^([A-Za-z][0-9]{1,2})|(([A-Za-z][A-Za-z][0-9]{1,2})|(([AZa-z][0-9][A-Za-z])|([A-Za-z][A-Za-z][0-9][A-Za-z]?)))? ?[0-9][A-Za-z]{2}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Ivy Cottage, Rockley,SN81RT
11 Brabourne Gardens, North Shields,NE299JB
2 Russell Gardens, Whitchurch,RG287AY
14 Red Barns, Newcastle Upon Tyne,NE12TP
1 Hollybank, Tamworth Road, Lichfield,WS149JE
69 Burnlee Road, Holmfirth,HD92PS
30 Cashio Lane, Letchworth Garden City,SG61AX
14 Cedartree Gardens, Whitley Bay,NE258XN
518A Victoria Road, Ruislip,HA40HD
9 Pear Avenue, Leeds,LS168GT
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$0@"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)