// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?m)^([A-Za-z][0-9]{1,2})|(([A-Za-z][A-Za-z][0-9]{1,2})|(([AZa-z][0-9][A-Za-z])|([A-Za-z][A-Za-z][0-9][A-Za-z]?)))? ?[0-9][A-Za-z]{2}$").unwrap();
let string = "Ivy Cottage, Rockley,SN81RT
11 Brabourne Gardens, North Shields,NE299JB
2 Russell Gardens, Whitchurch,RG287AY
14 Red Barns, Newcastle Upon Tyne,NE12TP
1 Hollybank, Tamworth Road, Lichfield,WS149JE
69 Burnlee Road, Holmfirth,HD92PS
30 Cashio Lane, Letchworth Garden City,SG61AX
14 Cedartree Gardens, Whitley Bay,NE258XN
518A Victoria Road, Ruislip,HA40HD
9 Pear Avenue, Leeds,LS168GT
";
let substitution = "$0@";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}