# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(#[^\s]+)/<a href='\/'>$1<\/a>/g;t' <<< "Ohhhh #ohhh #oh #ohh #ohhhh ohhh oh"