$re = '/(#[^\s]+)/';
$str = 'Ohhhh #ohhh #oh #ohh #ohhhh ohhh oh';
$subst = "<a href='/'>$1</a>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;