re = /(#[^\s]+)/
str = 'Ohhhh #ohhh #oh #ohh #ohhhh ohhh oh'
subst = '<a href=\'/\'>$1</a>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result