import Foundation
let pattern = ##"(#[^\s]+)"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"Ohhhh #ohhh #oh #ohh #ohhhh ohhh oh"##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<a href='/'>$1</a>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)