# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?!sofia$).*$//gmi;t' <<< "1245
sofia
Some text"