use strict;
my $str = '1245
sofia
Some text';
my $regex = qr/^(?!sofia$).*$/mip;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";