$re = '/^(?!sofia$).*$/mi';
$str = '1245
sofia
Some text';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;