const regex = /^(?!sofia$).*$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!sofia$).*$', 'gmi')
const str = `1245
sofia
Some text`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);