using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w+)\s*(?:=|<>|!=|<|>|>=|<=)\s*(:\w+)";
string input = @"SELECT GF010, GF030, GF140
FROM CAG.GFTB01
WHERE (
(GF030 BETWEEN :MIN AND :MAX)
OR
(GF140 BETWEEN :MIN AND :MAX)
) OPT
SELECT GF010, GF030, GF140
FROM CAG.GFTB01
WHERE (
(GF030 = :MAX)
OR
(GF140 BETWEEN :MIN AND :MAX)
) OPT
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}