use strict;
my $str = 'SELECT GF010, GF030, GF140
FROM CAG.GFTB01
WHERE (
(GF030 BETWEEN :MIN AND :MAX)
OR
(GF140 BETWEEN :MIN AND :MAX)
) OPT
SELECT GF010, GF030, GF140
FROM CAG.GFTB01
WHERE (
(GF030 = :MAX)
OR
(GF140 BETWEEN :MIN AND :MAX)
) OPT
';
my $regex = qr/(\w+)\s*(?:=|<>|!=|<|>|>=|<=)\s*(:\w+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}