import Foundation
let pattern = #"(\w+)\s*(?:=|<>|!=|<|>|>=|<=)\s*(:\w+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
SELECT GF010, GF030, GF140
FROM CAG.GFTB01
WHERE (
(GF030 BETWEEN :MIN AND :MAX)
OR
(GF140 BETWEEN :MIN AND :MAX)
) OPT
SELECT GF010, GF030, GF140
FROM CAG.GFTB01
WHERE (
(GF030 = :MAX)
OR
(GF140 BETWEEN :MIN AND :MAX)
) OPT
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)