re = /(\w+)\s*(?:=|<>|!=|<|>|>=|<=)\s*(:\w+)/m
str = 'SELECT GF010, GF030, GF140
FROM CAG.GFTB01
WHERE (
(GF030 BETWEEN :MIN AND :MAX)
OR
(GF140 BETWEEN :MIN AND :MAX)
) OPT
SELECT GF010, GF030, GF140
FROM CAG.GFTB01
WHERE (
(GF030 = :MAX)
OR
(GF140 BETWEEN :MIN AND :MAX)
) OPT
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end