using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:\r\n|\r|\n){2})[\r\n]+";
string substitution = @"$1";
string input = @"Привет
Мир!
Миру
Мир!";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}