$re = '%((?:\r\n|\r|\n){2})[\r\n]+%';
$str = 'Привет
Мир!
Миру
Мир!';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;