re = /((?:\r\n|\r|\n){2})[\r\n]+/
str = 'Привет
Мир!
Миру
Мир!'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result