import Foundation
let pattern = #"((?:\r\n|\r|\n){2})[\r\n]+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Привет
Мир!
Миру
Мир!
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)