import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(https?:\\/\\/)?(www\\.)?youtu\\.?be(\\.com\\/watch\\?v=)?\\/?";
final String string = "https://www.youtube.com/watch?v=a54d65asd45a6sd4\n"
+ "http://www.youtube.com/watch?v=aldkjalksdj1203\n"
+ "www.youtube.com/watch?v=\n"
+ "youtube.com/watch?v=\n"
+ "https://youtu.be/asdas123123\n"
+ "http://youtu.be/asdas123123\n"
+ "youtu.be/lakdjklj123";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}