import re
regex = re.compile(r"(https?:\/\/)?(www\.)?youtu\.?be(\.com\/watch\?v=)?\/?")
test_str = ("https://www.youtube.com/watch?v=a54d65asd45a6sd4\n"
"http://www.youtube.com/watch?v=aldkjalksdj1203\n"
"www.youtube.com/watch?v=\n"
"youtube.com/watch?v=\n"
"https://youtu.be/asdas123123\n"
"http://youtu.be/asdas123123\n"
"youtu.be/lakdjklj123")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")