use strict;
my $str = 'https://www.youtube.com/watch?v=a54d65asd45a6sd4
http://www.youtube.com/watch?v=aldkjalksdj1203
www.youtube.com/watch?v=
youtube.com/watch?v=
https://youtu.be/asdas123123
http://youtu.be/asdas123123
youtu.be/lakdjklj123';
my $regex = qr/(https?:\/\/)?(www\.)?youtu\.?be(\.com\/watch\?v=)?\/?/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}