re = /(([0-9]+\s?)+)(\$|EUR)/
str = 'player number 8 have a nice day. the price is 1 000 $ or you have to pay 2000$. 1000$ and 1000EUR'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end