using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(""version"".*:.*""\d.*(?=""))";
string substitution = @"${1}x123";
string input = @"{
""name"": ""myApp"",
""version"" : ""22.01.36""
}";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}