import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\"version\".*:.*\"\\d.*(?=\"))";
final String string = "{\n"
+ " \"name\": \"myApp\",\n"
+ " \"version\" : \"22.01.36\"\n"
+ "}";
final String subst = "${1}x123";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}