re = /("version".*:.*"\d.*(?="))/
str = '{
"name": "myApp",
"version" : "22.01.36"
}'
subst = '${1}x123'
result = str.sub(re, subst)
# Print the result of the substitution
puts result