use strict;
my $str = '{
"name": "myApp",
"version" : "22.01.36"
}';
my $regex = qr/("version".*:.*"\d.*(?="))/p;
my $subst = '${1}x123';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";