use strict;
my $str = '1234 AB';
my $regex = qr/^[1-9]{1}[0-9]{3} ?(?!sa|sd|ss)[a-zA-Z]{2}$/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";