import re
regex = re.compile(r"^[1-9]{1}[0-9]{3} ?(?!sa|sd|ss)[a-zA-Z]{2}$")
test_str = "1234 AB"
subst = ""
result = regex.sub(subst, test_str, count=1)
if result:
print(result)