re = /^[1-9]{1}[0-9]{3} ?(?!sa|sd|ss)[a-zA-Z]{2}$/
str = '1234 AB'
subst = ''
result = str.sub(re, subst)
# Print the result of the substitution
puts result