use strict;
my $str = ' "meta_description": "Singapore Company Profile - Azric International Business Services Pte Ltd - Management Consultants, Business Services, Business Consultants ",
"html_content": "<html>\\n <head><\\/head>\\n <body>\\n Azric International Business Services Pte Ltd - Management Consultants, Business Services, Business Consultants, Singapore Companies Directory \\n <table> \\n <tbody> \\n <tr> \\n <td> \\n <table> \\n <tbody> \\n <tr> \\n <td> \\n <table> \\n <tbody> \\n <tr> \\n <td> <\\/td> \\n <td> <\\/td> \\n <td> <\\/td> \\n <\\/tr> \\n <tr> \\n <td> <\\/td> \\n <td> \\n <table> \\n <tbody> \\n <tr> \\n <td> <a href=\\"http://singapore-companies-directory.com\\" target=\\"_blank\\"> Main<\\/a><\\/td> \\n <td> <a href=\\"http://singapore-companies-directory.com/aboutus.htm\\" target=\\"_blank\\"> About Us<\\/a><\\/td> \\n <td> <a href=\\"http://singapore-companies-directory.com/products", "other_data": 1
';
my $regex = qr/"html_content"\s*:\s*"(.*?(?<!\\))"/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}